Asked  7 Months ago    Answers:  5   Viewed   27 times

Can I use Lucene with PHP ? I don't want to use Zend. Can I use in native PHP (not framework) ?

 Answers

60

I would recommend using Apache SOLR as your Lucene backend and connecting via web service calls from your PHP code.

I'd also note that it's easy to pick and choose components of Zend Framework for use in your application without loading the entire framework. You could use Zend_Search_Lucene in your site and forego Zend's MVC, database, and related components.

Wednesday, March 31, 2021
 
MGP
answered 7 Months ago
MGP
86

You should point to your vendor/autoload.php at Settings | PHP | PHPUnit when using PHPUnit via Composer.

This blog post has all the details (with pictures) to successfully configure IDE for such scenario: http://confluence.jetbrains.com/display/PhpStorm/PHPUnit+Installation+via+Composer+in+PhpStorm

Related usability ticket: http://youtrack.jetbrains.com/issue/WI-18388

P.S. The WI-18388 ticket is already fixed in v8.0

Wednesday, March 31, 2021
 
ojrac
answered 7 Months ago
79

On Mac OS X environment variables available in Terminal and for the normal applications can be different, check the related question for the solution how to make them similar.

Note that this solution will not work on Mountain Lion (10.8).

Saturday, May 29, 2021
 
Nate
answered 5 Months ago
38

I guess that you are following the Amazon tutorial to install phpMyAdmin ?

I had the same problem today and resolved it by uninstall PHP 7.0 with the yum command (the same given by Amazon with 'remove' instead of 'install' :

sudo yum remove httpd24 php70 mysql56-server php70-mysqlnd

and installed PHP 5.6 instead :

sudo yum install httpd24 php56 mysql56-server php56-mysqlnd

I don't know if this is a good solution, but it worked and I could install phpMyAdmin without dependencies problem. I hope it will help :)

Tuesday, August 10, 2021
 
user336786
answered 3 Months ago
86

PHPUnit normally runs within the CLI - command line interface.

The PHP you've got there is different than with the webserver. Different binary and often a different configuration as well.

$ php -r "new mysqli();"

Should give you the same error. Verify where the binary and configuration is located:

$ which php

And

$ php -i | grep ini

Ensure you've got the extension for the mysqli class installed and enabled. Once configured you should be able to run your unit-tests flawlessly.

Sunday, August 22, 2021
 
David Heffernan
answered 2 Months ago
Only authorized users can answer the question. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :