Asked  7 Months ago    Answers:  5   Viewed   32 times

I installed PHP7 today with

sudo add-apt-repository ppa:ondrej/php-7.0
sudo apt-get install php7.0-cli php7.0-common libapache2-mod-php7.0 php7.0 php7.0-mysql php7.0-fpm

after this, I got 403 forbidden error when I tried to access phpmyadmin. then I tried to reinstall phpmyadmin with

apt-get install phpmyadmin

but it still looks for php5 dependencies which arent there anymore:

Image Description

what can I do to solve this?

 Answers

60

Install it via wget and create an alias in Apache. Keep track:

Change to directory /usr/share:

cd /usr/share

Change to root user:

 sudo su

Download phpMyAdmin:

wget https://files.phpmyadmin.net/phpMyAdmin/4.5.4.1/phpMyAdmin-4.5.4.1-all-languages.zip

Unzip it: (you may install unzip first)

unzip phpMyAdmin-4.5.4.1-all-languages.zip

Rename the folder:

mv phpMyAdmin-4.5.4.1-all-languages phpmyadmin

Change permissions:

chmod -R 0755 phpmyadmin

Configure apache so that it can find it correctly:

vim /etc/apache2/sites-available/000-default.conf

Anywhere after "DocumentRoot /var/www/html" insert these line:

Alias /phpmyadmin "/usr/share/phpmyadmin/"
<Directory "/usr/share/phpmyadmin/">
     Order allow,deny
     Allow from all
     Require all granted
</Directory>

Restart Apache:

service apache2 restart

And you are ready to go!

Just took a screenshot from my current installation for you to validate it works. enter image description here

Wednesday, March 31, 2021
 
mario
answered 7 Months ago
86

Edit: The real solution here is that the listen in www.conf and fastcgi_pass in nginx configuration have to match. Whether you use sockets or tcp is up to you.

The answer was to not use a .sock file at all.

in /etc/php-fpm.d/www.conf it has:

listen = 127.0.0.1:9000

So in my nginx config I put

fastcgi_pass 127.0.0.1:9000;

Instead of using something like

fastcgi_pass unix:/var/run/php/php7.0-fpm.sock;
Wednesday, March 31, 2021
 
binoculars
answered 7 Months ago
64

This error can be fixed, the following command will reconfigure your phpMyAdmin credentials to gain access to the MYSQL DB:

sudo dpkg-reconfigure phpmyadmin

/! This will provide few interactive menus that will allow you to reconfigure the phpMyAdmin package with NEW credentials /!

But you could also reconfigure it manually :

1 - Log into mysql as root

mysql -u root -p

2 - Make sure 'phpmyadmin' user exists :

SELECT User FROM mysql.user;

3 - Switch to the appropriate MYSQL DB :

use phpmyadmin;

4 - Set new password for the phpmyadmin user

UPDATE user SET password=PASSWORD('yourNewPassword') WHERE User='phpmyadmin';
Saturday, May 29, 2021
 
leebriggs
answered 5 Months ago
12

PHP7 is more strict with session handling for custom session handlers. Symfony's custom session handler for its write method is, for whatever reason, returning false. Previously this did not trigger an error but now it does.

Since we do not have a lot of information on which custom session handler you are using, I would suggest setting a different custom session handler if possible since most of them appear to return true.

Here are the different session handlers Symfony, most of them appear to explicitly return true except for the Memcache ones and WriteCheckSessionHandler:

https://github.com/symfony/symfony/tree/582f4753a343f230fbe18b4e9a0747d48351ddfb/src/Symfony/Component/HttpFoundation/Session/Storage/Handler

EDIT:

Since you mention the Snc Redis Bundle session handler, are you sure you are using the most up-to-date version? A year ago it was modified to always return true on write:

https://github.com/snc/SncRedisBundle/blob/master/Session/Storage/Handler/RedisSessionHandler.php

UPDATE

Submitted a bug to PHP to see if we can figure out a more useful error message for future versions (please vote or leave a comment on the bug report):

https://bugs.php.net/bug.php?id=71070

Thursday, July 29, 2021
 
ajreal
answered 3 Months ago
22

I have finally been able to find a solution.

I followed the answer of this post

The miracle code is

sudo add-apt-repository -y ppa:ubuntugis/ubuntugis-unstable
sudo apt update
sudo apt install gdal-bin python-gdal python3-gdal libgdal1-dev

thank you for your help

Saturday, August 7, 2021
 
Sisyphus
answered 3 Months ago
Only authorized users can answer the question. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :