Asked  7 Months ago    Answers:  5   Viewed   61 times

I have Apache 2.4 and php installed on Windows Server 2012.

Im trying to load the php_ldap.dll extension.

Here's what Ive done:

In php.ini I set the following:

extension_dir = "C:phpext"

extension=php_ldap.dll

Then, I made sure the dll was available at that path, yep, it's there:

enter image description here

phpinfo shows that I am editing the correct php.ini and the extension_dir is updated.

However, when I start Apache, php_ldap.dll is not loaded.

The Apache logs show this warning:

PHP Warning:  PHP Startup: Unable to load dynamic library 'C:\php\ext\php_ldap.dll' - The specified module could not be found.rn in Unknown on line 0

How can I fix this?

Also, what's with the \? Why is it doubling the "" and is that the problem?

 Answers

96

My best guess would be that a needed library is missing from your system. The php_ldap extensions requires that both libeay32.dll and ssleay32.dll is installed on the system:

From the ldap installation manual:

Note: Note to Win32 Users

In order for this extension to work, there are DLL files that must be available to the Windows system PATH. For information on how to do this, see the FAQ entitled "How do I add my PHP directory to the PATH on Windows". Although copying DLL files from the PHP folder into the Windows system directory also works (because the system directory is by default in the system's PATH), this is not recommended. This extension requires the following files to be in the PATH: libeay32.dll and ssleay32.dll Versions before PHP 4.3.0 additionally require libsasl.dll.

Saturday, May 29, 2021
 
osondoar
answered 7 Months ago
34

Run these commands from your Kafka root folder:

cd binwindows

Then run Zookeper server:

zookeeper-server-start.bat ....configzookeeper.properties

Then run Kafka server:

kafka-server-start.bat ....configserver.properties


The gotcha here is to run the .bat files from the /bin/windows folder, so after you run your servers with the steps above and want to follow up with the tutorial, make sure you are running the correct batch files to create topics and whatnot, e.g.:

Create a topic:

kafka-topics.bat --create --zookeeper localhost:2181 --replication-factor 1 --partitions 1 --topic test

List topics:

kafka-topics.bat --list --zookeeper localhost:2181

Wednesday, June 30, 2021
 
keisar
answered 5 Months ago
45

Can I successfully configure Apache/PHP to respond to this request?

Yes. Just use the MultiviewsMatch directive to tell Apache that it can serve .php files regardless of whether their MIME type is compatible with the Accept header:

<Files "*.php">
    MultiviewsMatch Any
</Files>

From the docs, the effect is as follows:

You may finally allow Any extensions to match, even if mod_mime doesn't recognize the extension.

Saturday, July 31, 2021
 
Jens
answered 4 Months ago
80

Figured it out: use Alias for #3, instead of VirtualHost, thus:

Alias /myproject "C:/path/to/my/project"
<Directory "C:/path/to/my/project">
  Options Indexes FollowSymLinks MultiViews ExecCGI
  AllowOverride All
  Order allow,deny
  Allow from all
</Directory>
Saturday, September 11, 2021
 
wheresrhys
answered 3 Months ago
10

Be sure to download the 1033x64msodbcsql.msi (4.4 MB) installer. Even though you are using PHP x86, you need the x64 installer since the OS is x64. I had the same issue and my app now works with PHP x86 after installing the x64 installer.

Tuesday, September 28, 2021
 
devo
answered 2 Months ago
Only authorized users can answer the question. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :
 
Share