Asked  7 Months ago    Answers:  5   Viewed   107 times

I wanted to switch to IntelliJ for forge modding (minecraft). When I do what they are saying to do on internet, I get a maven error...

            Unindexed remote maven repositories found. Disable...
            The following repositories used in your gradle projects were not indexed yet: 
            http://files.minecraftforge.net/maven
            If you want to use dependency completion for these repositories artifacts,
            Open Repositories List, select required repositories and press "Update" button

When I click update, it loads for half a second and then gives the same error again... I searched on internet and nobody seems to have my problem... help please ?

 Answers

20

Check idea.log for errors. It may fail with OutOfMemory error in which case you can try increasing the heap size for Maven Importer (VM options for importer) and IDE heap size.

Try not to exceed 750-1024m for -Xmx value if you are running on a 32-bit JVM (default), otherwise it may crash or fail to start.

If you need to use more heap, switch to 64-bit Java and specify the same 64-bit JVM for Maven (JDK for importer) in IntelliJ IDEA settings.

Another possible case is if IDE cannot connect to the Maven process. On some systems it's needed to edit the hosts file so that localhost resolves correctly.

There was also a bug caused by Nvidia driver (java process was crashing). Make sure you have the latest driver if this applies to your hardware.

If all the above doesn't help, share your idea.log file.

Note that indexing repositories is not required for working with a project, but it may indicate that Maven fails to work for one of the reasons above (or some other). See if the dependencies for the project were imported and if you can build the imported project in IDEA.

Some repositories cannot be indexed at all, in this case just ignore the error.

Tuesday, June 1, 2021
 
Trott
answered 7 Months ago
97

If you use the bundled Maven that comes with Idea 14.1, have a look here: Slow Intellij IDEA deployment . Using an installed Maven seems to be much faster.

enter image description here

Another improvement could be to change the JDK for importer (and probably the VM options for importer) from Use internal JRE to your own JDK: enter image description here

Tuesday, August 10, 2021
 
Saxophlutist
answered 4 Months ago
94

There's no easy method or tool to achieve what you're after. Primarily because of the following differences:

MCP:

[ModCoderPack] was created to help mod creators to decompile, change and recompile the Minecraft classes.

Forge:

[Forge] is a massive API and mod loader used by modders to hook into Minecraft code and create mods. Forge contains numerous hooks into the Minecraft game engine, allowing modders to create mods with a high level of compatibility

So Forge creates an accessible API for developing easily maintainable mods whereas MCP is used to create modified versions of Minecraft client/server, distinct from the concept of a mod.

Forge is built on top of MCP and adds lots of new functionality. Depending on your mods complexity, it would take a tremendous amount of effort to rewrite the mod directly into Minecraft's deobfuscated source code.

Unless you have very good reasons to need this, like the creator of MCP said, just use Forge!

Wednesday, September 1, 2021
 
ChriskOlson
answered 3 Months ago
54

Texturing is very different in 1.8. Here are some tutorials:

Updating Blocks;
Updating Items.

For both of the above:

  • Remove any GameRegistry.registerBlock from the main mod class. These should now be in the block/item's constructor.
  • Add a private final name field and create a getter for it.

For blocks:

  • In src/main/resources/assets/{MODID}/models/block you will need 2 JSON files.
    The first should be called {BLOCKNAME}.json and contain this:

    {
        "parent": "block/cube_all",
        "textures": {
            "all": "{MODID}:blocks/{BLOCKNAME}"
        }
    }
    

    The second has the same name, goes in src/main/resources/assets/{MODID}/models/item, and has this code:

    {
        "parent": "{MODID}:block/{BLOCKNAME}",
        "display": {
            "thirdperson": {
                "rotation": [ 10, -45, 170 ],
                "translation": [ 0, 1.5, -2.75 ],
                "scale": [ 0.375, 0.375, 0.375 ]
            }
        }
    }
    
  • Now in src/main/resources/assets/{MODID}/blockstates, you need 1 more JSON file. With the same name, it should hold this code:

    {
        "variants": {
            "normal": { "model": "{MODID}:{BLOCKNAME}" }
        }
    }
    

You should replace {MODID} and {BLOCKNAME} with your mod's ID and block's name, respectively.

Sunday, September 19, 2021
 
JohnnyW
answered 3 Months ago
100

Do the following steps:

  1. Find your pom.xml in your files
  2. Right click on it --> Maven --> Import
  3. Wait for the project to load :D
  4. Press ctrl+alt+shift+s (This opens the Projects window.)
  5. Go to libraries and see if they are empty (they shouldnt)
  6. If they are post your full pom.xml please so I can see the problem
  7. If you still have a problem got to File --> Invalidate Caches /Restart
  8. Go to maven and Reimport All Maven Projects
Monday, September 20, 2021
 
Andre
answered 3 Months ago
Only authorized users can answer the question. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :  
Share