Asked  7 Months ago    Answers:  5   Viewed   27 times

I've installed Visual Studio 2012 Release Preview, and it appears to be fine, but now when I try to use Visual Studio 2010 to compile C++ projects, I get the following error message:

LINK : fatal error LNK1123: failure during conversion to COFF: file invalid or corrupt

I'm not 100% sure of this, but it seems to be related to projects that have .rc (resource) files in them.

I've tried repairing Visual Studio 2010 from Add/Remove programs and rebooting, but this has no effect.

I also get the same error if I use Visual Studio 2012 RC to compile the C++ projects when set to use the Visual Studio 2010 toolset. Upgrading to the Visual Studio 2011 toolset fixes the problem (but of course I don't want to do this for production code).

Update: I've uninstalled Visual Studio 2012, rebooted, and the problem still persists! Help!

 Answers

98

This MSDN thread explains how to fix it.

To summarize:

  • Either disable incremental linking, by going to

    Project Properties 
       -> Configuration Properties 
           -> Linker (General) 
              -> Enable Incremental Linking -> "No (/INCREMENTAL:NO)"
    
  • or install VS2010 SP1.

Edits (@CraigRinger): Note that installing VS 2010 SP1 will remove the 64-bit compilers. You need to install the VS 2010 SP1 compiler pack to get them back.

This affects Microsoft Windows SDK 7.1 for Windows 7 and .NET 4.0 as well as Visual Studio 2010.

Tuesday, June 1, 2021
 
fret
answered 7 Months ago
90

I know it's not really without installing Visual Studio 2012, but:

If licensing costs are the biggest driver perhaps the Express for Windows Desktop edition could be an alternative. You could keep the installation to the minimum required to support C++ builds.

Thursday, July 29, 2021
 
Gersom
answered 5 Months ago
97

MSDN has this info now, though maybe not in a side-by-side comparison format:

What's New in Visual Studio 2012
What's New for Visual C# in Visual Studio 2012
Visual C# Breaking Changes in Visual Studio 2012

You can see MSDN blogger Jason Zander's top 12 reasons to upgrade.

And a slideshow showing new features focusing on Win8/XAML/LightSwitch.

Also, the price of VS Professional has been lowered from US$799 to US$499 (there's no longer an upgrade option for this version).

The available project types may be interesting to some:
Comparison Chart: New Project Types Visual Studio 11 vs. Visual Studio 10

Friday, August 13, 2021
 
LoicTheAztec
answered 4 Months ago
12

Yes, just modify the platform toolset (reference):

Property Pages->Configuration Properties->General, then click Platform Toolset and select the toolset you want. Depending on what you have installed, you should see v90 for MSVC2008 and v100 for MSVC2010.

There is also more detailed info here.

Monday, August 16, 2021
 
John Kugelman
answered 4 Months ago
86

All credits to ba__friend for the hint. The reason is the wrong cvtres.exe as described here.Disable the old one and all is fine (at least in my particular case).

Thursday, October 14, 2021
 
irom
answered 2 Months ago
Only authorized users can answer the question. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :  
Share