Asked  7 Months ago    Answers:  5   Viewed   37 times

I'm trying to install berta (v 0.6.3b) and I get this error:

Warning: session_start() [function.session-start]: open(/var/php_sessions/sess_a0d6b8422181739d10066fb60cebfe5d, O_RDWR) failed: No such file or directory (2) in /hermes/bosweb/web010/b100/ipg.ellieniemeyercom/engine/_classes/class.bertasecurity.php

on line 75 The error seems to happen on line 75 of class.bertasecurity.php (view source code)

What is wrong and how can I fix it?

 Answers

27

Make sure that session directory is writable or you can set a path yourself with:

session_save_path

This comment is also useful if you are using above function.

Wednesday, March 31, 2021
 
Bono
answered 7 Months ago
85

You are using a Unix socket. When reading "localhost" MySQL client libraries don't interpret it as TCP host "localhost" and resolve that name but use the default Socket location. For using TCP on the local machine you have to use 127.0.0.1 as hostname.

To specify the past use unix_socketinstead of host in the DSN. The location of the socket used for localhost can be defined at compile time or in some versions of PHP using pdo_mysql.default_socket in the php.ini.

Wednesday, March 31, 2021
 
Farnabaz
answered 7 Months ago
53

Change this and check it is working or not

require_once("includes/EliteScript.php");

to

require_once("../includes/EliteScript.php");

Explanation current code calling current directory/includes/EliteScript.php but your file in previous directory so you have to add ../ it will include file from previous directory.

Wednesday, March 31, 2021
 
Daveel
answered 7 Months ago
27

I solve this annoying problem by following instructions below:

  1. open /etc/php5/apache2/php.ini
  2. find ;session.save_path = "/tmp", this line may look also like this ;session.save_path = "/var/lib/php5"
  3. remove first semicolon from this line
  4. restart apache by executing sudo service apache2 restart

FYI: I work under Ubuntu 12.04 with apache2, php5, phpMyAdmin 4.0.5 so for different systems and servers file path may be a little different.

In case of any troubles check if directory from step 2. is writable for server.

Good luck.

Wednesday, March 31, 2021
 
John_BSDthos
answered 7 Months ago
18

The "empty delimiter" warning occurs when the second parameter to strpos is empty. You definitely have an empty value in $titles_array.

I have reproduced the warning here: http://3v4l.org/RnU3q

Try print_r($titles_array) right before your foreach loop.

Wednesday, March 31, 2021
 
Gordnfreeman
answered 7 Months ago
Only authorized users can answer the question. Please sign in first, or register a free account.
Not the answer you're looking for? Browse other questions tagged :
 
Share